#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(https?)(;.*;?(\b\1\b)(;.*)?|;;)$"
Local $sString = "http;;http" & @CRLF & _
"http;http;" & @CRLF & _
"https;;http" & @CRLF & _
"http;;https" & @CRLF & _
"https;;https" & @CRLF & _
"https;https;" & @CRLF & _
"http;http;" & @CRLF & _
"https;http;" & @CRLF & _
"https;https;" & @CRLF & _
"http;;" & @CRLF & _
"https;;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")