import re
regex = re.compile(r"^(https?)(;.*;?(\b\1\b)(;.*)?|;;)$", flags=re.MULTILINE)
test_str = ("http;;http\n"
"http;http;\n"
"https;;http\n"
"http;;https\n"
"https;;https\n"
"https;https;\n"
"http;http;\n"
"https;http;\n"
"https;https;\n"
"http;;\n"
"https;;")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")