re = /^(https?)(;.*;?(\b\1\b)(;.*)?|;;)$/m
str = 'http;;http
http;http;
https;;http
http;;https
https;;https
https;https;
http;http;
https;http;
https;https;
http;;
https;;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end