$re = '/^(https?)(;.*;?(\b\1\b)(;.*)?|;;)$/m';
$str = 'http;;http
http;http;
https;;http
http;;https
https;;https
https;https;
http;http;
https;http;
https;https;
http;;
https;;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);