import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(https?)(;.*;?(\\b\\1\\b)(;.*)?|;;)$";
final String string = "http;;http\n"
+ "http;http;\n"
+ "https;;http\n"
+ "http;;https\n"
+ "https;;https\n"
+ "https;https;\n"
+ "http;http;\n"
+ "https;http;\n"
+ "https;https;\n"
+ "http;;\n"
+ "https;;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}