#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sm)<tr>(?:(?:(?:(?!<\/tr>).)*?)\bWORD\b(?:.*?))<\/tr>"
Local $sString = "<tr>asfasfdaf NOWORD dgdsfg</tr>" & @CRLF & _
"" & @CRLF & _
"<tr>asfasfdaf WORD" & @CRLF & _
"sfdasf" & @CRLF & _
"afsd</tr>" & @CRLF & _
"<tr>asfasfdaf WORD sgs</tr>" & @CRLF & _
"<tr>WORD sgs</tr>" & @CRLF & _
"<tr>asfasfdaf WORD</tr>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")