import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<tr>(?:(?:(?:(?!<\\/tr>).)*?)\\bWORD\\b(?:.*?))<\\/tr>";
final String string = "<tr>asfasfdaf NOWORD dgdsfg</tr>\n\n"
+ "<tr>asfasfdaf WORD\n"
+ "sfdasf\n"
+ "afsd</tr>\n"
+ "<tr>asfasfdaf WORD sgs</tr>\n"
+ "<tr>WORD sgs</tr>\n"
+ "<tr>asfasfdaf WORD</tr>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}