$re = '/<tr>(?:(?:(?:(?!<\/tr>).)*?)\bWORD\b(?:.*?))<\/tr>/sm';
$str = '<tr>asfasfdaf NOWORD dgdsfg</tr>
<tr>asfasfdaf WORD
sfdasf
afsd</tr>
<tr>asfasfdaf WORD sgs</tr>
<tr>WORD sgs</tr>
<tr>asfasfdaf WORD</tr>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);