const regex = /<tr>(?:(?:(?:(?!<\/tr>).)*?)\bWORD\b(?:.*?))<\/tr>/sgm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<tr>(?:(?:(?:(?!<\\\/tr>).)*?)\\bWORD\\b(?:.*?))<\\\/tr>', 'sgm')
const str = `<tr>asfasfdaf NOWORD dgdsfg</tr>
<tr>asfasfdaf WORD
sfdasf
afsd</tr>
<tr>asfasfdaf WORD sgs</tr>
<tr>WORD sgs</tr>
<tr>asfasfdaf WORD</tr>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}