using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<tr>(?:(?:(?:(?!<\/tr>).)*?)\bWORD\b(?:.*?))<\/tr>";
string input = @"<tr>asfasfdaf NOWORD dgdsfg</tr>
<tr>asfasfdaf WORD
sfdasf
afsd</tr>
<tr>asfasfdaf WORD sgs</tr>
<tr>WORD sgs</tr>
<tr>asfasfdaf WORD</tr>";
RegexOptions options = RegexOptions.Singleline | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}