re = /<tr>(?:(?:(?:(?!<\/tr>).)*?)\bWORD\b(?:.*?))<\/tr>/m
str = '<tr>asfasfdaf NOWORD dgdsfg</tr>
<tr>asfasfdaf WORD
sfdasf
afsd</tr>
<tr>asfasfdaf WORD sgs</tr>
<tr>WORD sgs</tr>
<tr>asfasfdaf WORD</tr>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end