using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.+?):.*$";
string substitution = @"$1";
string input = @"Data02: Windows: CPU utilization
File02: Windows: CPU utilization
App02: Windows: CPU utilization
RDS01: Windows: CPU utilization
DC01: Windows: CPU utilization";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}