// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.+?):.*$").unwrap();
let string = "Data02: Windows: CPU utilization
File02: Windows: CPU utilization
App02: Windows: CPU utilization
RDS01: Windows: CPU utilization
DC01: Windows: CPU utilization";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}