const regex = /^(.+?):.*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.+?):.*$', 'gm')
const str = `Data02: Windows: CPU utilization
File02: Windows: CPU utilization
App02: Windows: CPU utilization
RDS01: Windows: CPU utilization
DC01: Windows: CPU utilization`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);