using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(?([A-Z0-9]{3})\)? \(?([A-Z0-9]{3})\)? \(?([A-Z0-9]{4})\)?";
string input = @"8009228080
(900) (CAT) BABA
(+1) (900) (289) (9000)
900.900.9000
(+1) (900) (289) (9000)
(+1) (900) 289 (9000)
+1 (900) 982 8728";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}