package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\(?([A-Z0-9]{3})\)? \(?([A-Z0-9]{3})\)? \(?([A-Z0-9]{4})\)?`)
var str = `8009228080
(900) (CAT) BABA
(+1) (900) (289) (9000)
900.900.9000
(+1) (900) (289) (9000)
(+1) (900) 289 (9000)
+1 (900) 982 8728`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}