re = /\(?([A-Z0-9]{3})\)? \(?([A-Z0-9]{3})\)? \(?([A-Z0-9]{4})\)?/
str = '8009228080
(900) (CAT) BABA
(+1) (900) (289) (9000)
900.900.9000
(+1) (900) (289) (9000)
(+1) (900) 289 (9000)
+1 (900) 982 8728'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end