import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(?([A-Z0-9]{3})\\)? \\(?([A-Z0-9]{3})\\)? \\(?([A-Z0-9]{4})\\)?";
final String string = "8009228080\n\n"
+ "(900) (CAT) BABA\n\n"
+ "(+1) (900) (289) (9000)\n\n"
+ "900.900.9000\n\n"
+ "(+1) (900) (289) (9000)\n\n"
+ "(+1) (900) 289 (9000)\n"
+ "+1 (900) 982 8728";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}