// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\(?([A-Z0-9]{3})\)? \(?([A-Z0-9]{3})\)? \(?([A-Z0-9]{4})\)?").unwrap();
let string = "8009228080
(900) (CAT) BABA
(+1) (900) (289) (9000)
900.900.9000
(+1) (900) (289) (9000)
(+1) (900) 289 (9000)
+1 (900) 982 8728";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}