# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*_(\d{4})_.*/\1/g;t' <<< "1_2_start_2007_3_end"