$re = '/.*_(\d{4})_.*/';
$str = '1_2_start_2007_3_end';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;