using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*_(\d{4})_.*";
string substitution = @"\1";
string input = @"1_2_start_2007_3_end";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}