package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*_(\d{4})_.*`)
var str = `1_2_start_2007_3_end`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}