import re
regex = re.compile(r".*_(\d{4})_.*")
test_str = "1_2_start_2007_3_end"
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)