#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ".*_(\d{4})_.*"
Local $sString = "1_2_start_2007_3_end"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)