import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+(\\,\\d+)*)x(\\d+(\\,\\d+)*)";
final String string = "А можно чуть усложнить задачу, а то у меня к вечеру пятницы мозг замылился :( допустим числа дробные, разделитель - запятая, то есть (цифра или запятая)x(цифра или запятая) ?\n"
+ "Например: 24,3x100,5";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}