const regex = /(\d+(\,\d+)*)x(\d+(\,\d+)*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+(\\,\\d+)*)x(\\d+(\\,\\d+)*)', 'gm')
const str = `А можно чуть усложнить задачу, а то у меня к вечеру пятницы мозг замылился :( допустим числа дробные, разделитель - запятая, то есть (цифра или запятая)x(цифра или запятая) ?
Например: 24,3x100,5`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}