// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d+(\,\d+)*)x(\d+(\,\d+)*)").unwrap();
let string = "А можно чуть усложнить задачу, а то у меня к вечеру пятницы мозг замылился :( допустим числа дробные, разделитель - запятая, то есть (цифра или запятая)x(цифра или запятая) ?
Например: 24,3x100,5";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}