re = /(\d+(\,\d+)*)x(\d+(\,\d+)*)/m
str = 'А можно чуть усложнить задачу, а то у меня к вечеру пятницы мозг замылился :( допустим числа дробные, разделитель - запятая, то есть (цифра или запятая)x(цифра или запятая) ?
Например: 24,3x100,5'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end