import Foundation
let pattern = #"(\d+(\,\d+)*)x(\d+(\,\d+)*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
А можно чуть усложнить задачу, а то у меня к вечеру пятницы мозг замылился :( допустим числа дробные, разделитель - запятая, то есть (цифра или запятая)x(цифра или запятая) ?
Например: 24,3x100,5
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)