import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\.\\d{4}).*";
final String string = "/* Note: input consist digits[0-9] and one dot'.' only, before the match starts. The input on first line and last line is invalid */\n\n"
+ "2323.34.34.34.34.\n"
+ "45454.454455445\n"
+ "24334.45654565\n"
+ "65.5643423f5623/556\n"
+ "24...34..43436";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}