import Foundation
let pattern = #"(?<=\.\d{4}).*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
/* Note: input consist digits[0-9] and one dot'.' only, before the match starts. The input on first line and last line is invalid */
2323.34.34.34.34.
45454.454455445
24334.45654565
65.5643423f5623/556
24...34..43436
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)