use strict;
my $str = '/* Note: input consist digits[0-9] and one dot\'.\' only, before the match starts. The input on first line and last line is invalid */
2323.34.34.34.34.
45454.454455445
24334.45654565
65.5643423f5623/556
24...34..43436';
my $regex = qr/(?<=\.\d{4}).*/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}