import re
regex = re.compile(r"(?<=\.\d{4}).*")
test_str = ("/* Note: input consist digits[0-9] and one dot'.' only, before the match starts. The input on first line and last line is invalid */\n\n"
"2323.34.34.34.34.\n"
"45454.454455445\n"
"24334.45654565\n"
"65.5643423f5623/556\n"
"24...34..43436")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")