re = /(?<=\.\d{4}).*/
str = '/* Note: input consist digits[0-9] and one dot\'.\' only, before the match starts. The input on first line and last line is invalid */
2323.34.34.34.34.
45454.454455445
24334.45654565
65.5643423f5623/556
24...34..43436'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end