#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^.+?N+(?=[^N]{3})"
Local $sString = "NNNNNNNNNNNNNGNNACNCNTGCNAGTCGAGCGGATGACGGGAGCTTGCTCCCGGATTCAGCGGCGGACGGGTGAGTAATGCCTAGGAATCTGCCNTGGTAGATCGNATCGATCGATCGNNTNNN"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)