use strict;
my $str = 'NNNNNNNNNNNNNGNNACNCNTGCNAGTCGAGCGGATGACGGGAGCTTGCTCCCGGATTCAGCGGCGGACGGGTGAGTAATGCCTAGGAATCTGCCNTGGTAGATCGNATCGATCGATCGNNTNNN';
my $regex = qr~^.+?N+(?=[^N]{3})~mp;
my $subst = '';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";