re = /^.+?N+(?=[^N]{3})/m
str = 'NNNNNNNNNNNNNGNNACNCNTGCNAGTCGAGCGGATGACGGGAGCTTGCTCCCGGATTCAGCGGCGGACGGGTGAGTAATGCCTAGGAATCTGCCNTGGTAGATCGNATCGATCGATCGNNTNNN'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result