$re = '~^.+?N+(?=[^N]{3})~m';
$str = 'NNNNNNNNNNNNNGNNACNCNTGCNAGTCGAGCGGATGACGGGAGCTTGCTCCCGGATTCAGCGGCGGACGGGTGAGTAATGCCTAGGAATCTGCCNTGGTAGATCGNATCGATCGATCGNNTNNN';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;