using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""key""\s*:\s*""\$\$([^$]*)\$\$""";
string substitution = @"""key"":""$($1)""";
string input = @"{ parameters: { ""key"" : ""$$value$$"" } }
{parameters:{ ""key"":""$$value$$"" } }
{parameters:{ ""key"":""$$value$$"" } }";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}