package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"key"\s*:\s*"\$\$([^$]*)\$\$"`)
var str = `{ parameters: { "key" : "$$value$$" } }
{parameters:{ "key":"$$value$$" } }
{parameters:{ "key":"$$value$$" } }`
var substitution = ""key":"$($1)""
fmt.Println(re.ReplaceAllString(str, substitution))
}