import Foundation
let pattern = #""key"\s*:\s*"\$\$([^$]*)\$\$""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{ parameters: { "key" : "$$value$$" } }
{parameters:{ "key":"$$value$$" } }
{parameters:{ "key":"$$value$$" } }
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""key":"$($1)""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)