$re = '/"key"\s*:\s*"\$\$([^$]*)\$\$"/m';
$str = '{ parameters: { "key" : "$$value$$" } }
{parameters:{ "key":"$$value$$" } }
{parameters:{ "key":"$$value$$" } }';
$subst = "\"key\":\"$($1)\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;