const regex = /"key"\s*:\s*"\$\$([^$]*)\$\$"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"key"\\s*:\\s*"\\$\\$([^$]*)\\$\\$"', 'gm')
const str = `{ parameters: { "key" : "\$\$value\$\$" } }
{parameters:{ "key":"\$\$value\$\$" } }
{parameters:{ "key":"\$\$value\$\$" } }`;
const subst = `"key":"$($1)"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);