package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:^|,)
([^,\r\n]+)
\s*,[,\s]*
(?=\1 (?![A-Za-zА-ЯЁа-яё]) )`)
var str = `Центральный федеральный округ,Москва
Центр альный федеральный округ Москва,Москва
Центральный федеральный округ,Москва,Москва
Центральный федеральный округ,Москва ,Москва
Центральный федеральный округ,Великий Устюг , Великий Устюг
Центральный федеральный округ,Великий Устюг,Великий Устюгов`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}