import Foundation
// WARNING: You included a flag that Swift doesn't support: X
// When this flag is set, it causes any backslash in the pattern that is followed by a letter that has no special meaning to cause an error.
// By default in Swift, a backslash followed by a letter with no special meaning will be treated as a literal.
let pattern = #"""
(?:^|,)
([^,\r\n]+)
\s*,[,\s]*
(?=\1 (?![A-Za-zА-ЯЁа-яё]) )
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
Центральный федеральный округ,Москва
Центральный федеральный округ Москва,Москва
Центральный федеральный округ,Москва,Москва
Центральный федеральный округ,Москва ,Москва
Центральный федеральный округ,Великий Устюг , Великий Устюг
Центральный федеральный округ,Великий Устюг,Великий Устюгов
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)