re = /(?:^|,)
([^,\r\n]+)
\s*,[,\s]*
(?=\1 (?![A-Za-zА-ЯЁа-яё]) )/mx
str = 'Центральный федеральный округ,Москва
Центральный федеральный округ Москва,Москва
Центральный федеральный округ,Москва,Москва
Центральный федеральный округ,Москва ,Москва
Центральный федеральный округ,Великий Устюг , Великий Устюг
Центральный федеральный округ,Великий Устюг,Великий Устюгов'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end