$re = '~(?:^|,)
([^,\r\n]+)
\s*,[,\s]*
(?=\1 (?![A-Za-zА-ЯЁа-яё]) )~mXx';
$str = 'Центральный федеральный округ,Москва
Центральный федеральный округ Москва,Москва
Центральный федеральный округ,Москва,Москва
Центральный федеральный округ,Москва ,Москва
Центральный федеральный округ,Великий Устюг , Великий Устюг
Центральный федеральный округ,Великий Устюг,Великий Устюгов';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);