import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|,)\n"
+ "([^,\\r\\n]+)\n"
+ "\\s*,[,\\s]*\n"
+ "(?=\\1 (?![A-Za-zА-ЯЁа-яё]) )";
final String string = "Центральный федеральный округ,Москва\n"
+ "Центральный федеральный округ Москва,Москва\n"
+ "Центральный федеральный округ,Москва,Москва\n"
+ "Центральный федеральный округ,Москва ,Москва\n"
+ "Центральный федеральный округ,Великий Устюг , Великий Устюг\n"
+ "Центральный федеральный округ,Великий Устюг,Великий Устюгов";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}