# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\"[^"]*\"\s*:\s*\[\s*\],?//gsm;t' <<< "{
\"rootname\" : {
\"key1\" : [ \"lbl1\", \"lbl2\" ],
\"key2\" : 10,
\"key3\" : [ ],
\"key4\" : \"hello\",
\"key5\" : []
}
}"